Surescripts Connectivity Issue
Incident Report for drchrono
Resolved
This issue has been resolved. Prescription Benefit and Medication History requests sent to MedImpact may not have been processed during the Surescripts connectivity downtime and will require a resend.
Posted 4 months ago. Jun 21, 2019 - 03:22 PDT
Identified
Surescripts is currently experiencing connectivity issues, specifically with Prescription Benefit and Medication History requests sent to MedImpact. These requests may not be processed at this time and will require a resend when full connectivity is restored. MedImpact and Surescripts engineers are currently working to resolve the issue.

DrChrono will communicate any updates from Surescripts once this issue is resolved.
Posted 4 months ago. Jun 20, 2019 - 07:13 PDT
This incident affected: eRx service.