DrChrono Service Downtime
Incident Report for drchrono
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 16, 2019 - 06:32 PDT
Identified
We are currently experiencing downtime of the DrChrono Service; we are investigating and working to fix the issue for all affected users. Some users may be experiencing a problem with saving clinical notes, appointments, and patient information.
Posted about 1 month ago. Aug 16, 2019 - 06:01 PDT
This incident affected: drchrono.com and drchrono iPad EHR.