Third Party Vendor-Updox
Incident Report for DrChrono
Resolved
Updox has notified us that the issue has been resolved. Please reach out to support if you still see issues with faxing.
Posted Apr 22, 2024 - 12:16 PDT
Investigating
Our 3rd party vendor, Updox is experiencing a disruption in service. Users may see slowness and errors when attempting to fax or when receiving faxes. We will continue to use this page to update you. We are sorry for any issues this may cause.
Posted Apr 22, 2024 - 10:56 PDT
This incident affected: drchrono.com.