EPCS Outage
Incident Report for drchrono
Resolved
We are pleased to report the previous EPCS outage is now resolved. We want to thank our users for their patience and support as we worked with our vendor to address this matter as quickly as possible.
Posted 8 months ago. Mar 12, 2018 - 16:11 PDT
Identified
drchrono is currently experiencing a service outage with EPCS capabilities. Please be aware that our engineering team is prioritizing the investigation of this issue and working to resolve this situation as quickly as possible. We will provide another update as soon as possible.
Posted 8 months ago. Mar 12, 2018 - 14:43 PDT