Service degradation with TriZetto eligibility services
Incident Report for drchrono
Resolved
Our team confirms that our eligibility service is back up and running. We appreciate your patience.
Posted 7 months ago. Mar 19, 2019 - 08:12 PDT
Update
Our team reports no slowness in our eligibility system in the last hour.
Posted 7 months ago. Mar 19, 2019 - 08:07 PDT
Identified
The TriZetto team has made changes and we're seeing substantial improvements in the success rate of eligibility checks. We believe eligibility services are mostly restored but with some slowness. We're currently confirming our findings with the TriZetto team and will provide an update soon.
Posted 7 months ago. Mar 19, 2019 - 06:56 PDT
Update
TriZetto reports that the slowness on their servers is a complex problem and requires in-depth investigation. Unfortunately, the TriZetto team has informed us that it is unlikely for a fix to be implemented by the end of today. We sincerely apologize for the inconvenience and thank you for your patience.
Posted 7 months ago. Mar 18, 2019 - 18:50 PDT
Investigating
We are experiencing substantial slowness and timeouts when connecting with TriZetto's eligibility services. Our team is actively working with TriZetto to reach a resolution. We apologize for the inconvenience.
Posted 7 months ago. Mar 18, 2019 - 16:36 PDT
This incident affected: drchrono.com and drchrono iPad EHR.