Vendor Outage Quest Diagnostics
Incident Report for DrChrono
Resolved
We have been notified by Quest Diagnostics that this issue has been resolved. We are sorry for any issues this may have caused you.
Posted Jul 17, 2024 - 11:28 PDT
Investigating
We have been made aware from our third party vendor, Quest that they are having system issues. This will effect lab orders, as well as receiving results. We will continue to use this page to monitor the status.
Posted Jul 16, 2024 - 12:13 PDT
This incident affected: 3rd party services (Quest Diagnostics).