LabCorp orders and results down
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 14:44 PST
Investigating
Placing orders via our LabCorp integration as well as receiving electronic results from LabCorp are both temporarily down. We are working to investigate these issues now and will provide an update with further information.
Posted Nov 16, 2020 - 13:58 PST
This incident affected: drchrono.com and drchrono iPad EHR.