Site Slowness
Incident Report for DrChrono
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 11:33 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2020 - 08:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 09, 2020 - 08:33 PDT
Investigating
We are currently investigating an issue that is causing general slowness and data not to save. We will provide an update as soon as possible regarding this issue.
Posted Sep 09, 2020 - 08:19 PDT
This incident affected: drchrono.com.