Site Outage
Incident Report for DrChrono
Postmortem

Customers were not able to access the DrChrono platform.

Summary

Issues occurred on February 18, 2022 where customers were unable to access the following: DrChrono website, iPad EHR, iPad Check-In app, and OnPatient.

Timeline (PST, 24-hour clock)

All times are PST.

Date/Time Activity
2022-02-18 10:19 Support team started to receive tickets about the site being inaccessible.
2022-02-18 10:19 DevOps investigates issue.
2022-02-18 10:30 Status page is created to reflect investigating status.
2022-02-18 10:31 DevOps identifies issues with missing system file directories.
2022-02-18 10:31 DevOps redeploys servers to create missing system file directories.
2022-02-18 10:53 Status page updated to reflect identified status.
2022-02-18 11:05 All servers have recreated the missing system file directories.
2022-02-18 11:11 Update is posted on status page to reflect all systems are operational.
2022-02-18 11:13 Status page updated to resolved.

Contributing Factor(s)

The primary factor was an erroneous script that was executed in an attempt to free web server disk space. The erroneous script removed the current system file directories instead of older releases.

Stabilization Steps

Redeploying the web servers with the latest code release re-created the missing/deleted system file directories.

Impact

All customers were unable to access the DrChrono website.

Corrective Actions

Aside from the stabilization steps mentioned, safeguards have been put in place to prevent further issues from arising. All potentially critical script and code executions on production will be vetted/executed through a front-running web server prior to production being accessed.

Posted Feb 24, 2022 - 13:44 PST

Resolved
This incident has been resolved.
Posted Feb 18, 2022 - 11:13 PST
Update
This incident has been resolved, and all systems are operational.
Posted Feb 18, 2022 - 11:11 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 18, 2022 - 10:53 PST
Investigating
DrChrono is currently inaccessible. We will provide an update here as soon as possible.
Posted Feb 18, 2022 - 10:30 PST
This incident affected: drchrono.com, drchrono iPad EHR, drchrono iPad Check-In Kiosk Application, DrChrono Telehealth Platform, onpatient.com, and onpatient iPhone PHR.