DrChrono Payments
Incident Report for DrChrono
Resolved
DrChrono has resolved the issue around payments. We are sorry for any issues this may have caused. Please reach out to support with any questions.
Posted May 24, 2024 - 07:08 PDT
Investigating
We are aware that some users may be experiencing an issue with their DrChrono Payments accounts appearing unlinked within DrChrono in the account settings. The back-end integrity of the connection between impacted users' accounts and DrChrono Payments is not affected, however, users may only see the "Enroll with DrChrono Payments Now" button in the Patient Payments set-up screen.

This may impact the ability to successfully run patient payments for DrChrono Payments users. Our team is investigating and we will update you as soon as we have further information
Posted May 24, 2024 - 06:57 PDT
This incident affected: drchrono.com, drchrono iPad EHR, drchrono iPad Check-In Kiosk Application, and DrChrono Telehealth Platform.